华为路由器RIP如何配置 华为路由器RIP配置步骤【介绍】

作者:小易整编 来源:小易整编 2022-06-18 03:43

  session 1 rip协议

  rip是一种动态路由协议,使用跳数作为度量标准,是距离矢量路由协议,是一种谣传式的路由协议。

  rip路由协议目前有2个版本,version 1 使用广播收发rip报文,并且不支持无类路由(更新报文中不带子网掩码)。version 2 使用组播或者广播(可以修改,默认组播)收发rip报文,支持无类路由(更新报文中带子网掩码)

  rip宣告网络只支持主类网络。

  rip是有进程之分的,可以同时运行多个rip进程,但是进程之间相互独立,如果要不同进程宣告网络,那么就必须在不同进程中相互重分发路由。

  rip的路由防环机制有:

  1、最大跳数:当一条路由到达16跳时,该路由失效,rip最大为16跳,也就是说最多可以经过16台设备,限制了网络的大小。

  2、水平分割:单向宣告网络,从一个接口收到的路由不会再从该接口宣告出去。

  3、毒性逆转:优化水平分割,从一个接口收到的路由会再从该接口宣告出去,但是该路由的跳数会自动设为16跳不可达。

  4、保持计时器:,收到的不可达路由信息被抑制的时间,默认180s,180s内路由器不会接受和发送该抑制路由的更新信息,若180s后没有更优的路由,该抑制路由将被删除。

  session 2 rip的配置

  一、rip的认证

  [Huawei-GigabitEthernet0/0/0]rip authentication-mode md5 usual cipher 123 在接口上做rip认证,MD5密文通用格式的加密,密码123(两端都需要配置)

  二、rip报文的单播发送和更新源检查

  1、单播发送rip报文,应用于NBMA非广播多路网络,如framerelay、ATM、X.25,解决了这些网络无法收发组播和广播报文的问题

  [Huawei]rip 1

  [Huawei-rip-1]peer 12.1.1.2 手动指定单播发送的rip邻居

  [Huawei-rip-1]quit

  2、rip检查更新源会检测对端接口是否和本端接口在同一个网段,在P2P网络中链路的两端ip地址属于不同的网段,必须取消报文源检测才能建立邻居关系

  [Huawei]rip 1

  [Huawei-rip-1]undo verify-source 关闭了更新源检测,默认情况下已开启

  [Huawei-rip-1]quit

  三、rip的发布聚合路由

  [Huawei]interface g0/0/0

  [Huawei-GigabitEthernet0/0/1]rip summary-address 192.168.0.0 255.255.0.0 avoid-feedback 向外宣告一条聚合路由,并且禁止从该接口学习到相同的聚合路由,以防止产生路由环路

  四、路由防环命令

  1、水平分割,开启水平分割功能,默认开启。

  [Huawei]interface g0/0/0

  [Huawei-GigabitEthernet0/0/1]rip split-horizon

  [Huawei-GigabitEthernet0/0/1]quit

  2、毒性反转,开启毒性反转功能,默认关闭。

  [Huawei]interface g0/0/0

  [Huawei-GigabitEthernet0/0/1]rip poison-reverse

  [Huawei-GigabitEthernet0/0/1]quit

  五、rip的路由选路

  1、rip路由的优先级默认值为100,在cisco中叫管理距离,用于和其他路由协议进行比较,值小的优先

  [Huawei]rip 1

  [Huawei-rip-1]preference 100 route-policy rip_first 设置rip的优先级为100,后面可选参数可以用路由策略来精确匹配哪些路由条目的优先级被设置为100

  [Huawei-rip-1]quit

  2、rip路由metric控制,在华为设备中显示的是cost

  [Huawei-GigabitEthernet0/0/0]rip metricin 2 设置接口g/0/0/0将接收到的路由条目metric增加2

  [Huawei-GigabitEthernet0/0/0]rip metricout 2 设置接口g/0/0/0将发送出的路由条目metric增加2

  [Huawei-GigabitEthernet0/0/0]rip metricin ip-prefix 17net 2 设置接口g/0/0/0将接收到的ip-prefix匹配的路由条目metric增加2(也可以用acl)

  六、rip的路由过滤

  1、过滤收到的路由

  [Huawei-rip-1]filter-policy 2999 import 在rip1中过滤掉acl2999中匹配到的接受的路由条目

  [Huawei-rip-1]silent-interface {GigabitEthernet | all} 抑制rip报文,只接收rip报文,但是不发送rip报文

  2、过滤发送的路由

  [Huawei-rip-1]filter-policy 2999 export 在rip1中过滤掉acl2999中匹配的要发送的路由条目

  3、默认路由

  [Huawei-rip-1]default-route originate cost 2 生成一条默认路由发送给邻居,cost为2

  session 3 rip重分发及路由过滤的实例配置

  AR1运行rip 1,AR3运行rip 3,AR2作为连接终点运行rip1与AR1建立邻居(其中AR1与AR2需要建立rip 1认证),而运行rip3与AR3建立邻居,为了使得AR1和AR3相互学习到不同rip进程中的路由,需要在AR2上进行路由重分发,将rip3与rip1中路由相互重分发,实现AR1与AR3的互通,并且要实现AR1只能学习到172.16.1.0/24的路由,而不允许学习到172.16.2.0/24网路,需要在AR2上做rip路由的分发过滤,将宣告给AR1的rip3中的路由条目172.16.2.0/24过滤掉。

  配置实例如下:

  AR1上的配置

  #

  interface GigabitEthernet0/0/0

  ip address 12.1.1.1 255.255.255.0

  rip authentication-mode md5 usual cipher %$%$2iu7P"~GlQCxjw6'[n2IC]5f%$%$ 配置与AR2的rip认证

  #

  interface GigabitEthernet0/0/1

  ip address 192.168.1.1 255.255.255.0

  #

  rip 1

  undo summary 关闭rip的路由汇总

  version 2

  network 12.0.0.0

  network 192.168.1.0

  #

  AR2上的配置

  #

  interface GigabitEthernet0/0/0

  ip address 12.1.1.2 255.255.255.0

  rip authentication-mode md5 usual cipher %$%$,EaAAs(q<*8PCJM\=C]/C`G\%$%$ 配置认证

  #

  interface GigabitEthernet0/0/1

  ip address 23.1.1.2 255.255.255.0

  #

  rip 1

  undo summary

  version 2

  network 12.0.0.0

  filter-policy ip-prefix deny2.0 export GigabitEthernet0/0/0 配置路由发布过滤,用ip-prefix匹配允许发布的路由

  import-route rip 3 将rip3重分发到rip1中,cost默认1

  #

  rip 3

  undo summary

  version 2

  network 23.0.0.0

  import-route rip 1 将rip1重分发到rip3中,cost默认1

  #

  ip ip-prefix deny2.0 index 10 permit 172.16.1.0 24 使用前缀列表抓取rip1中需要发布的路由

  #

  AR3上的配置

  #

  interface GigabitEthernet0/0/0

  ip address 23.1.1.3 255.255.255.0

  #

  interface GigabitEthernet0/0/1

  ip address 172.16.1.1 255.255.255.0

  #

  interface GigabitEthernet0/0/2

  ip address 172.16.2.1 255.255.255.0

  #

  rip 3

  undo summary

  version 2

  network 172.16.0.0

  network 23.0.0.0

  #

  检查配置结果,查看AR1上是否只有172.16.1.0/24路由在rip中被学习到。

  AR1上查看rip路由表

  [Huawei]display ip routing-table protocol rip

  Route Flags: R - relay, D - download to fib

  ------------------------------------------------------------------------------

  Public routing table : RIP

  Destinations : 1 Routes : 1

  RIP routing table status :

  Destinations : 1 Routes : 1

  Destination/Mask Proto Pre Cost Flags NextHop Interface

  172.16.1.0/24 RIP 100 1 D 12.1.1.2 GigabitEthernet0/0/0

  RIP routing table status :

  Destinations : 0 Routes : 0

  [Huawei]

  [Huawei]ping 172.16.1.1

  PING 172.16.1.1: 56 data bytes, press CTRL_C to break

  Reply from 172.16.1.1: bytes=56 Sequence=1 ttl=254 time=30 ms

  Reply from 172.16.1.1: bytes=56 Sequence=2 ttl=254 time=20 ms

  Reply from 172.16.1.1: bytes=56 Sequence=3 ttl=254 time=30 ms

  --- 172.16.1.1 ping statistics ---

  5 packet(s) transmitted

  5 packet(s) received

  0.00% packet loss

  round-trip min/avg/max = 20/28/30 ms

  [Huawei]


本文地址:IT疑问解答频道 http://www.hkm168.com/itwenda/8022.html,武汉易企推公司是一家专业的武汉网络推广,百度开户竞价托管,SEO网站优化公司,提供一站式全网营销服务:小程序开发,网站建设,SEO百度排名,SEM竞价托管,百度推广开户、360搜狗百度竞价开户、百度地图标注、百科词条创建修改、微信公众号代运营、公司负面公关处理等;另外,转载本文请保留本文地址,本站部分文章图片来自网络,本着互联网分享精神,如有侵犯到您的权益,请告知我们删除,谢谢!


相关文章相关文章
  • 华为网络设备基本配置,这7个命令你会几个?

    华为网络设备基本配置,这7个命令你会几个?

    华为网络设备基本配置,这7个命令你会几个?1、链路聚合是什么?链路聚合(link aggregation)是将多个物理接口当做一个逻辑接口,以增加带宽和提供线路冗余。链路聚合的带宽理论上相当于所包含的物理接口带宽总和,非常适用于企业核心网络...

    2022-07-06 07:07
  • Modem是什么

    Modem是什么

    Modem是什么 Modem是什么?常说的Modem,其实是Modulator(调制器)与Demodulator(解调器)的简称,中文称为调制解调器。也有人跟据Modem的谐音,亲昵地称之为 猫 。计...

    2022-06-21 06:06
  • 公共广播系统是什么

    公共广播系统是什么

    公共广播系统是什么 公共广播系统属于扩声音响系统中的一个分支,而扩声音响系统又称专业音响系统涉及电声、建声和乐声三种学科的边缘科学。所以公共广播系统最终效果涉及合理、正确的电声系统设计和调试,良好的声...

    2022-06-21 06:06
  • 路由器端口映射怎么设置

    路由器端口映射怎么设置

    路由器端口映射怎么设置?使用路由器后,Internet用户无法访问到局域网内的主机,因此不能访问内网搭建的Web、FTP、Mail等服务器。路由器端口映射功能可以实现将内网的服务器映射到Intern...

    2022-06-21 06:06
  • 什么牌子的路由器好

    什么牌子的路由器好

    移动设备的迅速崛起,让人们越来越依赖WiFi上网,路由器是连接各个网络的设备,同一个网络,多人同时使用,这就是路由器的主要功能。它以最佳的路径将接收到的信号发送出去。因此路由器现在广泛的应用到了各行...

    2022-06-21 06:06
  • 艾美加iX4怎么样

    艾美加iX4怎么样

    艾美加iX4怎么样 艾美加iX4是中小型办公场景和高级家庭用户,提供了双千兆网络接口,文件存取更快速。高阶功能方面支持iSCSI 块访问和多种RAID 配置,在灵活性与安全性方面完全可以满足企业用户的...

    2022-06-21 06:06
湖北SEO
孝感seo 十堰seo 恩施seo 咸宁seo 荆州seo 荆门seo 黄冈seo 黄石seo 襄阳seo 宜昌seo 随州seo 鄂州seo 天门seo 潜江seo 北京seo 天津seo 上海seo 重庆seo 西宁seo 拉萨seo 乌鲁木齐seo 武汉SEO优化 湖北网站建设 百度推广开户 巨量千川开户 危机公关处理 百度百科创建
河北SEO
石家庄seo 唐山seo 邯郸seo 保定seo 沧州seo 邢台seo 廊坊seo 承德seo 张家口seo 衡水seo 秦皇岛seo 河北网站建设 石家庄网站建设 河南网站建设 郑州网站建设
河南SEO
郑州seo 开封seo 洛阳seo 平顶山seo 焦作seo 鹤壁seo 新乡seo 安阳seo 濮阳seo 许昌seo 漯河seo 三门峡seo 南阳seo 商丘seo 信阳seo 周口seo 驻马店seo 济源seo
湖南SEO
长沙seo 株洲seo 湘潭seo 衡阳seo 邵阳seo 岳阳seo 常德seo 张家界seo 益阳seo 郴州seo 永州seo 怀化seo 娄底seo 湘西seo 湖南网站建设 长沙网站建设
江西SEO
南昌seo 九江seo 景德镇seo 上饶seo 鹰潭seo 抚州seo 宜春seo 新余seo 萍乡seo 吉安seo 赣州seo 江西网站建设 南昌网站建设
安徽SEO
合肥seo 黄山seo 芜湖seo 马鞍seo 安庆seo 淮南seo 阜阳seo 淮北seo 铜陵seo 亳州seo 宣城seo 蚌埠seo 六安seo 池州seo 滁州seo 宿州seo 安徽网站建设 合肥网站建设
山东SEO
济南seo 青岛seo 淄博seo 枣庄seo 东营seo 烟台seo 潍坊seo 济宁seo 泰安seo 威海seo 日照seo 临沂seo 德州seo 聊城seo 滨州seo 菏泽seo 山东网站建设 济南网站建设
江苏SEO
南京seo 无锡seo 徐州seo 常州seo 苏州seo 南通seo 连云港seo 淮安seo 盐城seo 扬州seo 镇江seo 泰州seo 宿迁seo 江苏网站建设 南京网站建设
浙江SEO
杭州seo 湖州seo 嘉兴seo 金华seo 丽水seo 宁波seo 衢州seo 绍兴seo 台州seo 温州seo 舟山seo 浙江网站建设 杭州网站建设
福建SEO
福州seo 厦门seo 泉州seo 漳州seo 莆田seo 宁德seo 龙岩seo 三明seo 南平seo 福建网站建设 福州网站建设
海南SEO
海口seo 三亚seo 三沙seo 儋州seo 网站建设公司 营销型网站 高端网站建设 模板网站制作 武汉APP开发 微信小程序开发 海南网站建设 海口网站建设
广东SEO
广州seo 深圳seo 珠海seo 汕头seo 佛山seo 韶关seo 湛江seo 肇庆seo 江门seo 茂名seo 惠州seo 梅州seo 汕尾seo 河源seo 阳江seo 清远seo 东莞seo 中山seo 潮州seo 揭阳seo 云浮seo 广东网站建设 广州网站建设 深圳网站建设
广西SEO
南宁seo 桂林seo 柳州seo 梧州seo 钦州seo 北海seo 玉林seo 贵港seo 防城港seo 百色seo 崇左seo 来宾seo 贺州seo 河池seo 广西网站建设 南宁网站建设
云南SEO
昆明seo 曲靖seo 玉溪seo 昭通seo 保山seo 丽江seo 普洱seo 临沧seo 德宏seo 怒江seo 迪庆seo 大理seo 楚雄seo 红河seo 文山seo 西双版纳seo 云南网站建设 昆明网站建设
贵州SEO
贵阳seo 遵义seo 六盘水seo 安顺seo 毕节seo 铜仁seo 黔东南seo 黔南seo 黔西南seo 贵州网站建设 贵阳网站建设
四川SEO
成都seo 自贡seo 攀枝花seo 泸州seo 德阳seo 绵阳seo 广元seo 遂宁seo 内江seo 乐山seo 南充seo 眉山seo 宜宾seo 广安seo 达州seo 雅安seo 巴中seo 资阳seo 阿坝seo 甘孜seo 凉山seo 四川网站建设 成都网站建设
山西SEO
太原seo 大同seo 朔州seo 忻州seo 阳泉seo 吕梁seo 晋中seo 长治seo 晋城seo 临汾seo 运城seo 山西网站建设 太原网站建设
陕西SEO
西安seo 宝鸡seo 咸阳seo 铜川seo 渭南seo 延安seo 榆林seo 汉中seo 安康seo 商洛seo 陕西网站建设 西安网站建设
甘肃SEO
兰州seo 嘉峪关seo 金昌seo 白银seo 天水seo 武威seo 张掖seo 平凉seo 酒泉seo 庆阳seo 定西seo 陇南seo 临夏seo 甘南seo 甘肃网站建设 兰州网站建设
宁夏SEO
银川seo 石嘴山seo 吴忠seo 固原seo 中卫seo 宁夏网站建设 银川网站建设 网络推广技巧 网络营销知识 武汉SEO顾问 武汉竞价托管 IT知识百科 IT疑问解答
内蒙古SEO
呼和浩特seo 包头seo 乌海seo 赤峰seo 通辽seo 鄂尔多斯seo 呼伦贝尔seo 巴彦淖尔seo 乌兰察布seo 内蒙古网站建设 呼和浩特网站建设
辽宁SEO
沈阳seo 大连seo 鞍山seo 抚顺seo 本溪seo 丹东seo 锦州seo 营口seo 阜新seo 辽阳seo 盘锦seo 铁岭seo 朝阳seo 葫芦岛seo 辽宁网站建设 沈阳网站建设
吉林SEO
长春seo 四平seo 辽源seo 通化seo 白山seo 松原seo 白城seo 延边seo 吉林网站建设 长春网站建设
黑龙江SEO
哈尔滨seo 齐齐哈尔seo 鹤岗seo 双鸭山seo 鸡西seo 大庆seo 伊春seo 牡丹江seo 佳木斯seo 七台河seo 黑河seo 绥化seo 黑龙江网站建设 哈尔滨网站建设
本地企业
              可提供上门服务

便捷

本地企业可提供上门服务

提供适合、专业可行方案

周到

提供适合、专业可行方案

5-10分钟售后响应机制<

贴心

5-10分钟售后响应机制

按效果收费,无效果不收费

放心

按效果收费,无效果不收费

行业高标准,效果稳定可靠

稳定

行业高标准,效果稳定可靠

1-3个月排名上百度首页

快速

1-3个月排名上百度首页

武汉易企推网络公司;公司地址:武汉市武昌区静安路6号5.5创意产业园4楼;公司官网:http://www.hkm168.com XML地图

服务热线:18120550335 (同微信,广告无扰) 欢迎来电咨询; 联系QQ:1193073039

Copyrigh©2017-2030 版权所有:武汉易企推网络科技有限公司 备案号:鄂ICP备17012199号 网站地图 手机站